Jump to content
  • 0
Sign in to follow this  
djmagnifique

Monitor flashes when TV is turned on

Question

My pc is connected to both a monitor and TV with the display extended accross them, TV is on the left and the monitor is on the right with the monitor being set as the primary display with the taskbar located on the monitor only.  If the pc is on and then the TV is turned on the monitor screen will flash off and on twice to a black/blank screen then continues to opperate normally.  Sometimes it will flash three times and this causes a problem as when it does this the TV is no longer detected as being connected and only restarting the pc fixes this and it moves all the desktop icons to the TV.  My graphics card is a GTX670 with 2 DVI, 1HDMI and 1 displayport connections.  The monitor is connected by DVI to DVI and the TV is connected by DVI to HDMI to the PC/DVI connection, I have tried connecting each one via HDMI to HDMI and tried changing which port they are connected to but it doesn't get rid of the problem.  The monitor is an Acer K242HL and the TV is a Samsung UE40K5500.

Anyone got any ideas as i'm not finding anything on Google.

Cheers.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Because the TV isn't on when you boot up for PC it doesn't recognise it as a multi-screen setup.

Once you turn it on (only having the PC Screen on to begin with) the PC/Graphics drivers try to reconfigure your setup for a multi-screen display and screws it up. With it being a TV and not a screen it acts differently/weirdly and the graphics card shits itself :P

That's the easiest way I can describe it hah, if you have 2 monitors then you won't get this issue.

 

Share this post


Link to post
Share on other sites
  • 0

Today I turned only the pc on and checked the dispay settings, it shows both the tv and the monitor as being connected even though the tv is turned off.  I then turned the tv on wihle haveing the display settings open, the tv disapperaed then reappeared as if the connection was getting refreshed.  It must be a Samsung thing as I don't remember it happening with my old LG tv.  Mind you I don't remember it doing this when I first got the tv either but I have updated the firmware when the Steamlink app so it might be something to do with one of them.

Share this post


Link to post
Share on other sites
  • 0

Well, Windows has recently updated to Fall Creators update which has kind of fixed this issue, instead of the monitor going black it now refreshes the desktop.  Only downside to this is that the Fall Creators update has broken the instant search in Outlook 2007 and support for Office 2007 expired a few months ago so it's probably not going to get fixed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×